#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\s{3}\d{1})"
Local $sString = "### ### ###" & @CRLF & _
" xxx" & @CRLF & _
"xxx" & @CRLF & _
"************" & @CRLF & _
" 3" & @CRLF & _
" 8" & @CRLF & _
"" & @CRLF & _
"END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")