$re = '/Chr\.(I(?!I)|III(?!I))/m';
$str = 'Chr.
Chr.I
Chr.II
Chr.III
Chr.IIV
Chr.IIII.I';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);