using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Chr\.(I(?!I)|III(?!I))";
string input = @"Chr.
Chr.I
Chr.II
Chr.III
Chr.IIV
Chr.IIII.I";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}