$re = '/<!-- AppInternalsXpert BMX Integration Begin -->(.*[\s\S]*)<!-- AppInternalsXpert BMX Integration End -->/im';
$str = '
<script>
$(function() {
$( ".tabs" ).tabs();
});
</script>
<!-- AppInternalsXpert BMX Integration Begin -->
<script>
if(!RVBD_EUE){
var RVBD_EUE={startJS:Number(new Date()),
clientId:\'\',appId:1,
collector:\'apmperformance.correios.com.br\',
collectorHttpPort:80, collectorHttpsPort:443,
sv:\'0401\',
ajax:true, sync:true,
ajaxResponseTime:true};
(function(){
var w=window,l=w.addEventListener,m=w.attachEvent,
d=document,s=\'script\',t=\'load\',o=RVBD_EUE,
r=((\'https:\'===d.location.protocol)?
\'https://apmperformance.correios.com.br:443\':
\'http://apmperformance.correios.com.br:80\')+
\'/jsi/riverbed_appinternals.d.\'+
(o.ajax?\'ajax.js\':\'js\'),p=(\'onpagehide\' in w),e=p?\'pageshow\':t,
j=d.createElement(s),x=d.getElementsByTagName(s)[0],
h=function(y){o.ldJS=o.ldJS||new Date();o.per=y?y.persisted:null;},
i=function(){o.ld=1;};o.cookie=d.cookie;d.cookie=
\'_op_aixPageId=0; path=/; expires=\'+(new Date(0)).toGMTString();
o.cookieAfterDelete=d.cookie;j.async=1;j.src=r;
if(l){l(e,h,false);if(p){l(t,i,false);}}else if(m)
{m(\'on\'+e,h);if(p){m(\'on\'+t,i);}}
if(o.sync){d.write(\'<\'+s+\' src=\\\'\'+r+\'\\\'></\'+s+\'>\');}
else{x.parentNode.insertBefore(j,x);}
})();}
</script>
<script>if(!RVBD_EUE_PARAM){var RVBD_EUE_PARAM={};} RVBD_EUE_PARAM.pageId = \'a2_e6e8c617-d7ec-4acd-a432-08b0febc30e0\';</script>
<!-- AppInternalsXpert BMX Integration End -->
[cadastrado]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);