$re = '/(?:(?:\-{1})?\d+(?:\.{1})?)/m';
$str = '-1
2
2.17';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);