package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?:\-{1})?\d+(?:\.{1})?)`)
var str = `-1
2
2.17`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}