import Foundation
let pattern = #"failing[\w\W]*?\d*\)\s[\w\W]*?\:\n[\s\S]*?(Assert[\w\W]*?)[\n].*(src\/[^:]+):(\d+):(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[0m[0m
[0m statement:propose[0m
[31m 1) validates input[0m
[92m [0m[32m 0 passing[0m[90m (1s)[0m
[31m 1 failing[0m
[0m 1) statement:propose validates input:
[0m[31m AssertionError: expected { Object (status, err) } to have a deep property 'err' of 'err1', but got 'Error while fetching the changes from the event store: {"error":"not_found","reason":"missing"}'[0m[90m
at doAsserterAsyncAndAddThen (node_modules/chai-as-promised/lib/chai-as-promised.js:307:16)
at .<anonymous> (node_modules/chai-as-promised/lib/chai-as-promised.js:255:21)
at ctx.(anonymous function) [as property] (node_modules/chai/lib/chai/utils/overwriteMethod.js:49:33)
at Context.<anonymous> (src/aggregate/test/index.js:21:36)
at Request.init (node_modules/request/request.js:191:10)
at new Request (node_modules/request/request.js:130:8)
at request (node_modules/request/index.js:54:10)
at Future._computation (src/aggregate/index.js:375:7)
at FutureNode$fork [as _f] (node_modules/fluture/fluture.js:910:10)
at FutureMap$fork [as _f] (node_modules/fluture/fluture.js:1239:26)
at FutureChain$fork$res (node_modules/fluture/fluture.js:1188:18)
at FutureMap$fork$res (node_modules/fluture/fluture.js:1240:7)
at FutureNode$fork$done (node_modules/fluture/fluture.js:912:22)
at node_modules/level-sublevel/shell.js:102:12
at node_modules/level-sublevel/nut.js:122:19
at Immediate.callNext (node_modules/memdown/memdown.js:173:5)
at MemDOWN._get (node_modules/memdown/memdown.js:172:3)
at MemDOWN.AbstractLevelDOWN.get (node_modules/abstract-leveldown/abstract-leveldown.js:94:17)
at Object.get (node_modules/level-sublevel/nut.js:117:28)
at EventEmitter.emitter.get (node_modules/level-sublevel/shell.js:100:9)
at Future._computation (src/aggregate/index.js:368:49)
at FutureNode$fork [as _f] (node_modules/fluture/fluture.js:910:10)
at FutureMap$fork [as _f] (node_modules/fluture/fluture.js:1239:26)
at FutureChain$fork$res (node_modules/fluture/fluture.js:1188:18)
at FutureOf$fork [as _f] (node_modules/fluture/fluture.js:871:5)
at FutureChain$fork$res (node_modules/fluture/fluture.js:1188:18)
at FutureOf$fork [as _f] (node_modules/fluture/fluture.js:871:5)
at FutureChain$fork [as _f] (node_modules/fluture/fluture.js:1185:29)
at FutureChain$fork [as _f] (node_modules/fluture/fluture.js:1185:29)
at FutureChain$fork [as _f] (node_modules/fluture/fluture.js:1185:29)
at FutureChain$fork [as _f] (node_modules/fluture/fluture.js:1185:29)
at FutureChain$fork [as _f] (node_modules/fluture/fluture.js:1185:29)
at FutureMap$fork [as _f] (node_modules/fluture/fluture.js:1239:26)
at FutureMapRej$fork [as _f] (node_modules/fluture/fluture.js:1259:26)
at Future$fork [as fork] (node_modules/fluture/fluture.js:252:17)
at Seneca.<anonymous> (src/aggregate/index.js:205:10)
at execute_action (node_modules/seneca/seneca.js:1092:20)
at Object.act_fn [as fn] (node_modules/seneca/seneca.js:1042:11)
at Immediate.processor (node_modules/gate-executor/gate-executor.js:136:14)
at work_fn_callback (node_modules/gate-executor/gate-executor.js:195:7)
at Seneca.reply (node_modules/seneca/seneca.js:1046:13)
at src/aggregate/index.js:63:16
at FutureNode$fork$done (node_modules/fluture/fluture.js:912:22)
at node_modules/level-sublevel/shell.js:53:51
at Immediate.<anonymous> (node_modules/level-sublevel/nut.js:109:13)
at MemDOWN._batch (node_modules/memdown/memdown.js:208:3)
at MemDOWN.AbstractLevelDOWN.batch (node_modules/abstract-leveldown/abstract-leveldown.js:189:17)
at Object.apply (node_modules/level-sublevel/nut.js:87:23)
at EventEmitter.emitter.put (node_modules/level-sublevel/shell.js:49:9)
at Future._computation (src/aggregate/index.js:369:56)
at FutureNode$fork [as _f] (node_modules/fluture/fluture.js:910:10)
at FutureChainRej$fork$rej (node_modules/fluture/fluture.js:1219:18)
at FutureNode$fork$done (node_modules/fluture/fluture.js:912:13)
at node_modules/level-sublevel/shell.js:101:15
at node_modules/level-sublevel/nut.js:121:19
at Immediate.callNext (node_modules/memdown/memdown.js:166:47)
at MemDOWN._get (node_modules/memdown/memdown.js:166:12)
at MemDOWN.AbstractLevelDOWN.get (node_modules/abstract-leveldown/abstract-leveldown.js:94:17)
at Object.get (node_modules/level-sublevel/nut.js:117:28)
at EventEmitter.emitter.get (node_modules/level-sublevel/shell.js:100:9)
at Future._computation (src/aggregate/index.js:368:49)
at FutureNode$fork [as _f] (node_modules/fluture/fluture.js:910:10)
at FutureChain$fork$res (node_modules/fluture/fluture.js:1188:18)
at FutureOf$fork [as _f] (node_modules/fluture/fluture.js:871:5)
at FutureChain$fork [as _f] (node_modules/fluture/fluture.js:1185:29)
at FutureChainRej$fork [as _f] (node_modules/fluture/fluture.js:1216:29)
at Future$fork [as fork] (node_modules/fluture/fluture.js:252:17)
at Seneca.<anonymous> (src/aggregate/index.js:61:8)
at execute_action (node_modules/seneca/seneca.js:1092:20)
at Object.act_fn [as fn] (node_modules/seneca/seneca.js:1042:11)
at processor (node_modules/gate-executor/gate-executor.js:136:14)
at Immediate.<anonymous> (node_modules/gate-executor/gate-executor.js:240:7)
at GateExecutor.self.start (node_modules/gate-executor/gate-executor.js:233:5)
at Object.gate [as fn] (node_modules/gate-executor/gate-executor.js:329:10)
at Immediate.processor (node_modules/gate-executor/gate-executor.js:136:14)
at work_fn_callback (node_modules/gate-executor/gate-executor.js:195:7)
at work_fn_callback (node_modules/gate-executor/gate-executor.js:186:11)
at Seneca.reply (node_modules/seneca/seneca.js:1046:13)
at Seneca.<anonymous> (src/state/index.js:49:12)
at execute_action (node_modules/seneca/seneca.js:1092:20)
at Object.act_fn [as fn] (node_modules/seneca/seneca.js:1042:11)
at processor (node_modules/gate-executor/gate-executor.js:136:14)
at Immediate.<anonymous> (node_modules/gate-executor/gate-executor.js:240:7)
at GateExecutor.self.start (node_modules/gate-executor/gate-executor.js:233:5)
at Object.gate [as fn] (node_modules/gate-executor/gate-executor.js:329:10)
at Immediate.processor (node_modules/gate-executor/gate-executor.js:136:14)
at work_fn_callback (node_modules/gate-executor/gate-executor.js:195:7)
at work_fn_callback (node_modules/gate-executor/gate-executor.js:186:11)
at Seneca.reply (node_modules/seneca/seneca.js:1046:13)
at handle_inward_break (node_modules/seneca/seneca.js:1211:13)
at execute_action (node_modules/seneca/seneca.js:1082:11)
at Object.act_fn [as fn] (node_modules/seneca/seneca.js:1042:11)
at processor (node_modules/gate-executor/gate-executor.js:136:14)
at Immediate.<anonymous> (node_modules/gate-executor/gate-executor.js:240:7)
at GateExecutor.self.start (node_modules/gate-executor/gate-executor.js:233:5)
at Object.gate [as fn] (node_modules/gate-executor/gate-executor.js:329:10)
at processor (node_modules/gate-executor/gate-executor.js:136:14)
at Immediate.<anonymous> (node_modules/gate-executor/gate-executor.js:240:7)
at GateExecutor.self.start (node_modules/gate-executor/gate-executor.js:233:5)
at make_seneca (node_modules/seneca/seneca.js:507:6)
at init (node_modules/seneca/seneca.js:224:16)
at Object.<anonymous> (test/unit/helper.js:28:17)
at loader (node_modules/babel-register/lib/node.js:144:5)
at Object.require.extensions.(anonymous function) [as .js] (node_modules/babel-register/lib/node.js:154:7)
at require (internal/module.js:20:19)
at Array.forEach (native)
at run (bootstrap_node.js:394:7)
at startup (bootstrap_node.js:149:9)
at bootstrap_node.js:509:3
[0m
(node:11964) Warning: a promise was created in a handler at Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb-replicator/lib/index.js:87:24 but was not returned from it, see http://goo.gl/rRqMUw
at new Promise (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/bluebird/js/release/promise.js:79:10)
(node:11964) Warning: a promise was created in a handler at Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/express-pouchdb/lib/daemon-manager.js:28:16 but was not returned from it, see http://goo.gl/rRqMUw
at Function.Promise.cast (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/bluebird/js/release/promise.js:196:13)
(node:11964) Warning: a promise was created in a handler at Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/express-pouchdb/lib/daemon-manager.js:28:16 but was not returned from it, see http://goo.gl/rRqMUw
at new Promise (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/bluebird/js/release/promise.js:79:10)
(node:11964) Warning: a promise was rejected with a non-error: [object String]
(node:11964) Warning: a promise was created in a handler at Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/express-pouchdb/lib/routes/authentication.js:96:7 but was not returned from it, see http://goo.gl/rRqMUw
at new Promise (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/bluebird/js/release/promise.js:79:10)
Unhandled rejection {"status":404,"name":"not_found","message":"missing","reason":"missing"}
(No stack trace)
From previous event:
at PouchDB$5.<anonymous> (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:117:19)
at PouchDB$5.get (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/argsarray/index.js:14:18)
at PouchDB$5.<anonymous> (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb-wrappers/index.js:155:18)
at securityWrapper (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb-security/lib/index.js:55:12)
at callHandlers (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb-wrappers/index.js:447:17)
at PouchDB$5.get (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb-wrappers/index.js:154:12)
at Object.filter (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:3849:26)
at Changes$2.doChanges (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:1638:45)
at /Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:1598:12
at Object.validate (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:3786:3)
at Changes$2.validateChanges (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:1594:36)
at /Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:1551:14
at TaskQueue$1.execute (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:2580:7)
at TaskQueue$1.ready (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:2593:8)
at /Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:2740:20
at /Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:4913:15
at _combinedTickCallback (internal/process/next_tick.js:67:7)
at process._tickCallback (internal/process/next_tick.js:98:9)
Error while loading the aggregate state Error while fetching the changes from the event store: {"error":"not_found","reason":"missing"}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)