#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "failing[\w\W]*?\d*\)\s[\w\W]*?\:\n[\s\S]*?(Assert[\w\W]*?)[\n].*(src\/[^:]+):(\d+):(\d+)"
Local $sString = "" & @CRLF & _
"[0m[0m" & @CRLF & _
"[0m statement:propose[0m" & @CRLF & _
" [31m 1) validates input[0m" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[92m [0m[32m 0 passing[0m[90m (1s)[0m" & @CRLF & _
"[31m 1 failing[0m" & @CRLF & _
"" & @CRLF & _
"[0m 1) statement:propose validates input:" & @CRLF & _
"[0m[31m AssertionError: expected { Object (status, err) } to have a deep property 'err' of 'err1', but got 'Error while fetching the changes from the event store: {"error":"not_found","reason":"missing"}'[0m[90m" & @CRLF & _
" at doAsserterAsyncAndAddThen (node_modules/chai-as-promised/lib/chai-as-promised.js:307:16)" & @CRLF & _
" at .<anonymous> (node_modules/chai-as-promised/lib/chai-as-promised.js:255:21)" & @CRLF & _
" at ctx.(anonymous function) [as property] (node_modules/chai/lib/chai/utils/overwriteMethod.js:49:33)" & @CRLF & _
" at Context.<anonymous> (src/aggregate/test/index.js:21:36)" & @CRLF & _
" at Request.init (node_modules/request/request.js:191:10)" & @CRLF & _
" at new Request (node_modules/request/request.js:130:8)" & @CRLF & _
" at request (node_modules/request/index.js:54:10)" & @CRLF & _
" at Future._computation (src/aggregate/index.js:375:7)" & @CRLF & _
" at FutureNode$fork [as _f] (node_modules/fluture/fluture.js:910:10)" & @CRLF & _
" at FutureMap$fork [as _f] (node_modules/fluture/fluture.js:1239:26)" & @CRLF & _
" at FutureChain$fork$res (node_modules/fluture/fluture.js:1188:18)" & @CRLF & _
" at FutureMap$fork$res (node_modules/fluture/fluture.js:1240:7)" & @CRLF & _
" at FutureNode$fork$done (node_modules/fluture/fluture.js:912:22)" & @CRLF & _
" at node_modules/level-sublevel/shell.js:102:12" & @CRLF & _
" at node_modules/level-sublevel/nut.js:122:19" & @CRLF & _
" at Immediate.callNext (node_modules/memdown/memdown.js:173:5)" & @CRLF & _
" at MemDOWN._get (node_modules/memdown/memdown.js:172:3)" & @CRLF & _
" at MemDOWN.AbstractLevelDOWN.get (node_modules/abstract-leveldown/abstract-leveldown.js:94:17)" & @CRLF & _
" at Object.get (node_modules/level-sublevel/nut.js:117:28)" & @CRLF & _
" at EventEmitter.emitter.get (node_modules/level-sublevel/shell.js:100:9)" & @CRLF & _
" at Future._computation (src/aggregate/index.js:368:49)" & @CRLF & _
" at FutureNode$fork [as _f] (node_modules/fluture/fluture.js:910:10)" & @CRLF & _
" at FutureMap$fork [as _f] (node_modules/fluture/fluture.js:1239:26)" & @CRLF & _
" at FutureChain$fork$res (node_modules/fluture/fluture.js:1188:18)" & @CRLF & _
" at FutureOf$fork [as _f] (node_modules/fluture/fluture.js:871:5)" & @CRLF & _
" at FutureChain$fork$res (node_modules/fluture/fluture.js:1188:18)" & @CRLF & _
" at FutureOf$fork [as _f] (node_modules/fluture/fluture.js:871:5)" & @CRLF & _
" at FutureChain$fork [as _f] (node_modules/fluture/fluture.js:1185:29)" & @CRLF & _
" at FutureChain$fork [as _f] (node_modules/fluture/fluture.js:1185:29)" & @CRLF & _
" at FutureChain$fork [as _f] (node_modules/fluture/fluture.js:1185:29)" & @CRLF & _
" at FutureChain$fork [as _f] (node_modules/fluture/fluture.js:1185:29)" & @CRLF & _
" at FutureChain$fork [as _f] (node_modules/fluture/fluture.js:1185:29)" & @CRLF & _
" at FutureMap$fork [as _f] (node_modules/fluture/fluture.js:1239:26)" & @CRLF & _
" at FutureMapRej$fork [as _f] (node_modules/fluture/fluture.js:1259:26)" & @CRLF & _
" at Future$fork [as fork] (node_modules/fluture/fluture.js:252:17)" & @CRLF & _
" at Seneca.<anonymous> (src/aggregate/index.js:205:10)" & @CRLF & _
" at execute_action (node_modules/seneca/seneca.js:1092:20)" & @CRLF & _
" at Object.act_fn [as fn] (node_modules/seneca/seneca.js:1042:11)" & @CRLF & _
" at Immediate.processor (node_modules/gate-executor/gate-executor.js:136:14)" & @CRLF & _
" at work_fn_callback (node_modules/gate-executor/gate-executor.js:195:7)" & @CRLF & _
" at Seneca.reply (node_modules/seneca/seneca.js:1046:13)" & @CRLF & _
" at src/aggregate/index.js:63:16" & @CRLF & _
" at FutureNode$fork$done (node_modules/fluture/fluture.js:912:22)" & @CRLF & _
" at node_modules/level-sublevel/shell.js:53:51" & @CRLF & _
" at Immediate.<anonymous> (node_modules/level-sublevel/nut.js:109:13)" & @CRLF & _
" at MemDOWN._batch (node_modules/memdown/memdown.js:208:3)" & @CRLF & _
" at MemDOWN.AbstractLevelDOWN.batch (node_modules/abstract-leveldown/abstract-leveldown.js:189:17)" & @CRLF & _
" at Object.apply (node_modules/level-sublevel/nut.js:87:23)" & @CRLF & _
" at EventEmitter.emitter.put (node_modules/level-sublevel/shell.js:49:9)" & @CRLF & _
" at Future._computation (src/aggregate/index.js:369:56)" & @CRLF & _
" at FutureNode$fork [as _f] (node_modules/fluture/fluture.js:910:10)" & @CRLF & _
" at FutureChainRej$fork$rej (node_modules/fluture/fluture.js:1219:18)" & @CRLF & _
" at FutureNode$fork$done (node_modules/fluture/fluture.js:912:13)" & @CRLF & _
" at node_modules/level-sublevel/shell.js:101:15" & @CRLF & _
" at node_modules/level-sublevel/nut.js:121:19" & @CRLF & _
" at Immediate.callNext (node_modules/memdown/memdown.js:166:47)" & @CRLF & _
" at MemDOWN._get (node_modules/memdown/memdown.js:166:12)" & @CRLF & _
" at MemDOWN.AbstractLevelDOWN.get (node_modules/abstract-leveldown/abstract-leveldown.js:94:17)" & @CRLF & _
" at Object.get (node_modules/level-sublevel/nut.js:117:28)" & @CRLF & _
" at EventEmitter.emitter.get (node_modules/level-sublevel/shell.js:100:9)" & @CRLF & _
" at Future._computation (src/aggregate/index.js:368:49)" & @CRLF & _
" at FutureNode$fork [as _f] (node_modules/fluture/fluture.js:910:10)" & @CRLF & _
" at FutureChain$fork$res (node_modules/fluture/fluture.js:1188:18)" & @CRLF & _
" at FutureOf$fork [as _f] (node_modules/fluture/fluture.js:871:5)" & @CRLF & _
" at FutureChain$fork [as _f] (node_modules/fluture/fluture.js:1185:29)" & @CRLF & _
" at FutureChainRej$fork [as _f] (node_modules/fluture/fluture.js:1216:29)" & @CRLF & _
" at Future$fork [as fork] (node_modules/fluture/fluture.js:252:17)" & @CRLF & _
" at Seneca.<anonymous> (src/aggregate/index.js:61:8)" & @CRLF & _
" at execute_action (node_modules/seneca/seneca.js:1092:20)" & @CRLF & _
" at Object.act_fn [as fn] (node_modules/seneca/seneca.js:1042:11)" & @CRLF & _
" at processor (node_modules/gate-executor/gate-executor.js:136:14)" & @CRLF & _
" at Immediate.<anonymous> (node_modules/gate-executor/gate-executor.js:240:7)" & @CRLF & _
" at GateExecutor.self.start (node_modules/gate-executor/gate-executor.js:233:5)" & @CRLF & _
" at Object.gate [as fn] (node_modules/gate-executor/gate-executor.js:329:10)" & @CRLF & _
" at Immediate.processor (node_modules/gate-executor/gate-executor.js:136:14)" & @CRLF & _
" at work_fn_callback (node_modules/gate-executor/gate-executor.js:195:7)" & @CRLF & _
" at work_fn_callback (node_modules/gate-executor/gate-executor.js:186:11)" & @CRLF & _
" at Seneca.reply (node_modules/seneca/seneca.js:1046:13)" & @CRLF & _
" at Seneca.<anonymous> (src/state/index.js:49:12)" & @CRLF & _
" at execute_action (node_modules/seneca/seneca.js:1092:20)" & @CRLF & _
" at Object.act_fn [as fn] (node_modules/seneca/seneca.js:1042:11)" & @CRLF & _
" at processor (node_modules/gate-executor/gate-executor.js:136:14)" & @CRLF & _
" at Immediate.<anonymous> (node_modules/gate-executor/gate-executor.js:240:7)" & @CRLF & _
" at GateExecutor.self.start (node_modules/gate-executor/gate-executor.js:233:5)" & @CRLF & _
" at Object.gate [as fn] (node_modules/gate-executor/gate-executor.js:329:10)" & @CRLF & _
" at Immediate.processor (node_modules/gate-executor/gate-executor.js:136:14)" & @CRLF & _
" at work_fn_callback (node_modules/gate-executor/gate-executor.js:195:7)" & @CRLF & _
" at work_fn_callback (node_modules/gate-executor/gate-executor.js:186:11)" & @CRLF & _
" at Seneca.reply (node_modules/seneca/seneca.js:1046:13)" & @CRLF & _
" at handle_inward_break (node_modules/seneca/seneca.js:1211:13)" & @CRLF & _
" at execute_action (node_modules/seneca/seneca.js:1082:11)" & @CRLF & _
" at Object.act_fn [as fn] (node_modules/seneca/seneca.js:1042:11)" & @CRLF & _
" at processor (node_modules/gate-executor/gate-executor.js:136:14)" & @CRLF & _
" at Immediate.<anonymous> (node_modules/gate-executor/gate-executor.js:240:7)" & @CRLF & _
" at GateExecutor.self.start (node_modules/gate-executor/gate-executor.js:233:5)" & @CRLF & _
" at Object.gate [as fn] (node_modules/gate-executor/gate-executor.js:329:10)" & @CRLF & _
" at processor (node_modules/gate-executor/gate-executor.js:136:14)" & @CRLF & _
" at Immediate.<anonymous> (node_modules/gate-executor/gate-executor.js:240:7)" & @CRLF & _
" at GateExecutor.self.start (node_modules/gate-executor/gate-executor.js:233:5)" & @CRLF & _
" at make_seneca (node_modules/seneca/seneca.js:507:6)" & @CRLF & _
" at init (node_modules/seneca/seneca.js:224:16)" & @CRLF & _
" at Object.<anonymous> (test/unit/helper.js:28:17)" & @CRLF & _
" at loader (node_modules/babel-register/lib/node.js:144:5)" & @CRLF & _
" at Object.require.extensions.(anonymous function) [as .js] (node_modules/babel-register/lib/node.js:154:7)" & @CRLF & _
" at require (internal/module.js:20:19)" & @CRLF & _
" at Array.forEach (native)" & @CRLF & _
" at run (bootstrap_node.js:394:7)" & @CRLF & _
" at startup (bootstrap_node.js:149:9)" & @CRLF & _
" at bootstrap_node.js:509:3" & @CRLF & _
"[0m" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(node:11964) Warning: a promise was created in a handler at Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb-replicator/lib/index.js:87:24 but was not returned from it, see http://goo.gl/rRqMUw" & @CRLF & _
" at new Promise (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/bluebird/js/release/promise.js:79:10)" & @CRLF & _
"(node:11964) Warning: a promise was created in a handler at Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/express-pouchdb/lib/daemon-manager.js:28:16 but was not returned from it, see http://goo.gl/rRqMUw" & @CRLF & _
" at Function.Promise.cast (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/bluebird/js/release/promise.js:196:13)" & @CRLF & _
"(node:11964) Warning: a promise was created in a handler at Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/express-pouchdb/lib/daemon-manager.js:28:16 but was not returned from it, see http://goo.gl/rRqMUw" & @CRLF & _
" at new Promise (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/bluebird/js/release/promise.js:79:10)" & @CRLF & _
"(node:11964) Warning: a promise was rejected with a non-error: [object String]" & @CRLF & _
"(node:11964) Warning: a promise was created in a handler at Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/express-pouchdb/lib/routes/authentication.js:96:7 but was not returned from it, see http://goo.gl/rRqMUw" & @CRLF & _
" at new Promise (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/bluebird/js/release/promise.js:79:10)" & @CRLF & _
"Unhandled rejection {"status":404,"name":"not_found","message":"missing","reason":"missing"}" & @CRLF & _
" (No stack trace)" & @CRLF & _
"From previous event:" & @CRLF & _
" at PouchDB$5.<anonymous> (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:117:19)" & @CRLF & _
" at PouchDB$5.get (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/argsarray/index.js:14:18)" & @CRLF & _
" at PouchDB$5.<anonymous> (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb-wrappers/index.js:155:18)" & @CRLF & _
" at securityWrapper (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb-security/lib/index.js:55:12)" & @CRLF & _
" at callHandlers (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb-wrappers/index.js:447:17)" & @CRLF & _
" at PouchDB$5.get (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb-wrappers/index.js:154:12)" & @CRLF & _
" at Object.filter (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:3849:26)" & @CRLF & _
" at Changes$2.doChanges (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:1638:45)" & @CRLF & _
" at /Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:1598:12" & @CRLF & _
" at Object.validate (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:3786:3)" & @CRLF & _
" at Changes$2.validateChanges (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:1594:36)" & @CRLF & _
" at /Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:1551:14" & @CRLF & _
" at TaskQueue$1.execute (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:2580:7)" & @CRLF & _
" at TaskQueue$1.ready (/Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:2593:8)" & @CRLF & _
" at /Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:2740:20" & @CRLF & _
" at /Users/jun/dev/OII/current/oi/code/aggregates/statement/node_modules/pouchdb/lib/index.js:4913:15" & @CRLF & _
" at _combinedTickCallback (internal/process/next_tick.js:67:7)" & @CRLF & _
" at process._tickCallback (internal/process/next_tick.js:98:9)" & @CRLF & _
"Error while loading the aggregate state Error while fetching the changes from the event store: {"error":"not_found","reason":"missing"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")