import Foundation
let pattern = #"Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*)\s+(?P<log_time>.*),Microsoft-Windows-Security-Auditing,(?P<event_id>\d+),(?P<category>.*),(?P<event_message>.*)\s+(?P<audit_message>.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Audit Success,08/03/2017 18:57:56,Microsoft-Windows-Security-Auditing,4608,Security State Change,"Windows is starting up.
This event is logged when LSASS.EXE starts and the auditing subsystem is initialized."
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)