// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*)\s+(?P<log_time>.*),Microsoft-Windows-Security-Auditing,(?P<event_id>\d+),(?P<category>.*),(?P<event_message>.*)\s+(?P<audit_message>.*)").unwrap();
let string = "Audit Success,08/03/2017 18:57:56,Microsoft-Windows-Security-Auditing,4608,Security State Change,\"Windows is starting up.
This event is logged when LSASS.EXE starts and the auditing subsystem is initialized.\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}