$re = '/(country=).*?(;|$)/i';
$str = '/uk/flights/results/country=BG;from-city=Kiev;from=IEV,KBP;to=BOJ,PDV,SOF,VAR;dates=2018-07-15,2018-07-29/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);