# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(((\+44\s?\d{4}|\(?0\d{4}\)?)\s?\d{3}\s?\d{3})|((\+44\s?\d{3}|\(?0\d{3}\)?)\s?\d{3}\s?\d{4})|((\+44\s?\d{2}|\(?0\d{2}\)?)\s?\d{4}\s?\d{4}))(\s?\#(\d{4}|\d{3}))?$"
test_str = ("+447222555555\n"
"+44 7222 555 555\n"
"(0722) 5555555 #2222\n"
"07222 55555\n"
"(07222) 555555\n"
"(07222) 555555\n\n"
"(+447222)555555\n"
"+44(7222)555555\n"
"(0722) 5555555 #22\n\n"
"+4401612223333\n"
"+44(0)1612223333\n"
"+441612223333\n"
"+44 1612223333\n"
"+44(0)161 2223333\n"
"+44(0)161 222 3333")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.