using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((\+44\s?\d{4}|\(?0\d{4}\)?)\s?\d{3}\s?\d{3})|((\+44\s?\d{3}|\(?0\d{3}\)?)\s?\d{3}\s?\d{4})|((\+44\s?\d{2}|\(?0\d{2}\)?)\s?\d{4}\s?\d{4}))(\s?\#(\d{4}|\d{3}))?$";
string input = @"+447222555555
+44 7222 555 555
(0722) 5555555 #2222
07222 55555
(07222) 555555
(07222) 555555
(+447222)555555
+44(7222)555555
(0722) 5555555 #22
+4401612223333
+44(0)1612223333
+441612223333
+44 1612223333
+44(0)161 2223333
+44(0)161 222 3333";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}