re = /SSR.(....)(.BE.)(\w+)(-1)(\w+)(\/)(\w+).*/m
str = 'SSR BAGW BE HK1DUBEXT0304H13OCT-1TIMBRELL/TEGAELAMISS.1P/AUTH 23KG
SSR BAGA BE HK1DUBLON0301H13NOV-1TIMBRELL/TEGAELAMISS.1P/AUTH 23KG
SSR DOCS BE HK1DUBEXT0204H13DEC-1TIMBRELL/TEGAELAMISS
SSR PETC BE HK1LONEXT0334H13JAN-1TIMBRELL/TEGAELAMISS
SSR WCHR BE HK1DUBEXT0204H13DEC-1TIMBRELL/TEGAELAMISS
SSR BAGW BE HK1DUBLON0301H13NOV-1TIMBRELL/TEGAELAMISS.1P/AUTH 23KG
BE7351 H 08NOV18MANMXP HK4/11251440
BE2108R/VS8508Y 11NOV18LHREDI HK10/18202000
A97351 H 08NOV18MANMXP HK4/11251440'
subst = '\\1-\\5-\\7'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result