import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SSR.(....)(.BE.)(\\w+)(-1)(\\w+)(\\/)(\\w+).*";
final String string = "SSR BAGW BE HK1DUBEXT0304H13OCT-1TIMBRELL/TEGAELAMISS.1P/AUTH 23KG\n"
+ "SSR BAGA BE HK1DUBLON0301H13NOV-1TIMBRELL/TEGAELAMISS.1P/AUTH 23KG\n"
+ "SSR DOCS BE HK1DUBEXT0204H13DEC-1TIMBRELL/TEGAELAMISS\n"
+ "SSR PETC BE HK1LONEXT0334H13JAN-1TIMBRELL/TEGAELAMISS\n"
+ "SSR WCHR BE HK1DUBEXT0204H13DEC-1TIMBRELL/TEGAELAMISS\n"
+ "SSR BAGW BE HK1DUBLON0301H13NOV-1TIMBRELL/TEGAELAMISS.1P/AUTH 23KG\n"
+ "BE7351 H 08NOV18MANMXP HK4/11251440\n"
+ "BE2108R/VS8508Y 11NOV18LHREDI HK10/18202000\n"
+ "A97351 H 08NOV18MANMXP HK4/11251440";
final String subst = "\\1-\\5-\\7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}