// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z]{2,4})").unwrap();
let string = "JakobCJakobsen@einrot.com+1 (845) 858-7707
johndoe@email.com1234567890
304-438-2648SandraCTaylor@dayrep.com
978-243-8596JuanPerez@teleworm.us
413-259-3637BuiQuynhChan@fleckens.hu
AlexCrawford@dayrep.com+1 (208) 264-9063
StefanijaNovosel@teleworm.us1 518 487 4865";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}