#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z]{2,4})"
Local $sString = "JakobCJakobsen@einrot.com+1 (845) 858-7707" & @CRLF & _
"johndoe@email.com1234567890" & @CRLF & _
"304-438-2648SandraCTaylor@dayrep.com" & @CRLF & _
"978-243-8596JuanPerez@teleworm.us" & @CRLF & _
"413-259-3637BuiQuynhChan@fleckens.hu" & @CRLF & _
"AlexCrawford@dayrep.com+1 (208) 264-9063" & @CRLF & _
"StefanijaNovosel@teleworm.us1 518 487 4865"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")