package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/\*ext-vscode-rickroll-start\*\/[\s\S]*?\/\*ext-vscode-rickroll-end\*\/`)
var str = `/*ext-${vscode-rickroll}-start*/
@keyframes doRick{
from {
transform: scale(2);
opacity:1;
}
to {
transform: scale(1);
opacity:0.7;
}
}
body{
animation: doRick 1.8s linear 1 normal forwards;
background-size:contain;
opacity:1;
animation-delay: 2.4s;
background-repeat: no-repeat;
background-position:center center;
background-image:url('${base64image}');
}
/*ext-${vscode-rickroll}-end*/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}