using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*ext-vscode-rickroll-start\*\/[\s\S]*?\/\*ext-vscode-rickroll-end\*\/";
string input = @"/*ext-${vscode-rickroll}-start*/
@keyframes doRick{
from {
transform: scale(2);
opacity:1;
}
to {
transform: scale(1);
opacity:0.7;
}
}
body{
animation: doRick 1.8s linear 1 normal forwards;
background-size:contain;
opacity:1;
animation-delay: 2.4s;
background-repeat: no-repeat;
background-position:center center;
background-image:url('${base64image}');
}
/*ext-${vscode-rickroll}-end*/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}