# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)[\da-f]{8}-[\da-f]{4}-[\da-f]{4}-[\da-f]{4}-[\da-f]{12}"
test_str = ("e876c866-1dd6-4c32-bf27-7ab673b57f75\n"
"d9da6fe0-cf69-40ae-9263-a115aac94441\n"
"bc783e58-3cac-4efb-92ee-560b696674c8\n"
"7b054304-c5dd-4595-a390-fd4f4b700e33\n"
"20255eea-5679-4fa7-8e65-4bab69425727\n"
"8039e4c6-4032-4065-8723-b0351d4a33f0\n"
"e9b3f927-b87a-459a-8a5b-caba3ccc8968\n"
"edbdb831-6e92-4241-8ba9-0bba71a1d7b0\n"
"087b5b52-97e6-4341-8976-59674ecbef2d\n"
"d78be4c5-a0ba-4ef4-ab77-97585aa61436")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.