#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)[\da-f]{8}-[\da-f]{4}-[\da-f]{4}-[\da-f]{4}-[\da-f]{12}"
Local $sString = "e876c866-1dd6-4c32-bf27-7ab673b57f75" & @CRLF & _
"d9da6fe0-cf69-40ae-9263-a115aac94441" & @CRLF & _
"bc783e58-3cac-4efb-92ee-560b696674c8" & @CRLF & _
"7b054304-c5dd-4595-a390-fd4f4b700e33" & @CRLF & _
"20255eea-5679-4fa7-8e65-4bab69425727" & @CRLF & _
"8039e4c6-4032-4065-8723-b0351d4a33f0" & @CRLF & _
"e9b3f927-b87a-459a-8a5b-caba3ccc8968" & @CRLF & _
"edbdb831-6e92-4241-8ba9-0bba71a1d7b0" & @CRLF & _
"087b5b52-97e6-4341-8976-59674ecbef2d" & @CRLF & _
"d78be4c5-a0ba-4ef4-ab77-97585aa61436"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")