// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\-?[0-9]*\.[0-9][0-9]*(E\-?[0-9]+)?").unwrap();
let string = "0.12345
-0.12345
123.45678
.12345
-0.12345E12
123.45678E-123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}