re = /\-?[0-9]*\.[0-9][0-9]*(E\-?[0-9]+)?/m
str = '0.12345
-0.12345
123.45678
.12345
-0.12345E12
123.45678E-123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end