// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(compile|testCompile|implementation|testImplementation|compileOnly|runtime|testRuntime|[a-zA-Z0-9_]{1,100})\sgroup\:\s['"](.*)['"],\sname\:\s['"](.*)['"],\sversion\:\s['"](.*)['"]|(compile|testCompile|implementation|testImplementation|compileOnly|runtime|testRuntime|[a-zA-Z0-9_]{1,100})\s['"](.*):(.*):(.*)['"]|(compile|testCompile|implementation|testImplementation|compileOnly|runtime|testRuntime|[a-zA-Z0-9_]{1,100})\(['"](.*):(.*):(.*)['"]\)"#).unwrap();
let string = "compile group: 'commons-net', name: 'commons-net', version: '3.1.2'
testCompile group: 'org.spockframework', name: 'spock-core', version: '2.0-M1-groovy-3.0'
implementation group: 'commons-net', name: 'commons-net', version: '3.7.2'
testImplementation group: 'org.spockframework', name: 'spock-core', version: '2.0-M4-groovy-3.0'
implementation \"org.apache.httpcomponents:httpclient:latest.release\"
implementation 'org.apache.httpcomponents:httpclient:1.0.0'
compile \"com.h2database:h2:1.4.197\"
compile(\"com.github.bkenn:kfoenix:0.1.2-SNAPSHOT\")
compile group: \"com.jfoenix\", name: \"jfoenix\", version: \"8.0.7\"
compile \"org.jooq:jooq:3.11.5\"
jooqRuntime('com.h2database:h2:1.4.197')
jooqRuntime(\"com.h2database:h2:1.4.197\")
jooqRuntime 'com.h2database:h2:1.4.197'
jooqRuntime \"com.h2database:h2:1.4.197\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}