import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(compile|testCompile|implementation|testImplementation|compileOnly|runtime|testRuntime|[a-zA-Z0-9_]{1,100})\\sgroup\\:\\s['\"](.*)['\"],\\sname\\:\\s['\"](.*)['\"],\\sversion\\:\\s['\"](.*)['\"]|(compile|testCompile|implementation|testImplementation|compileOnly|runtime|testRuntime|[a-zA-Z0-9_]{1,100})\\s['\"](.*):(.*):(.*)['\"]|(compile|testCompile|implementation|testImplementation|compileOnly|runtime|testRuntime|[a-zA-Z0-9_]{1,100})\\(['\"](.*):(.*):(.*)['\"]\\)";
final String string = "compile group: 'commons-net', name: 'commons-net', version: '3.1.2'\n"
+ "testCompile group: 'org.spockframework', name: 'spock-core', version: '2.0-M1-groovy-3.0'\n"
+ "implementation group: 'commons-net', name: 'commons-net', version: '3.7.2'\n"
+ "testImplementation group: 'org.spockframework', name: 'spock-core', version: '2.0-M4-groovy-3.0'\n"
+ "implementation \"org.apache.httpcomponents:httpclient:latest.release\"\n"
+ "implementation 'org.apache.httpcomponents:httpclient:1.0.0'\n"
+ "compile \"com.h2database:h2:1.4.197\"\n"
+ "compile(\"com.github.bkenn:kfoenix:0.1.2-SNAPSHOT\")\n"
+ "compile group: \"com.jfoenix\", name: \"jfoenix\", version: \"8.0.7\"\n"
+ "compile \"org.jooq:jooq:3.11.5\"\n"
+ "jooqRuntime('com.h2database:h2:1.4.197')\n"
+ "jooqRuntime(\"com.h2database:h2:1.4.197\")\n"
+ "jooqRuntime 'com.h2database:h2:1.4.197'\n"
+ "jooqRuntime \"com.h2database:h2:1.4.197\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}