import Foundation
let pattern = #"(?<MyLastParagraph>.*\s)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
gula. Morbi tincidunt purus ac pharetra vehicula. Aenean convallis tristique eros hendrerit porttitor.
Morbi tristique massa ligula, vel interdum dui ultricies hendrerit. In blandit ultrices arcu, et accumsan nulla bibendum sed.
Proin quis tortor lacinia, ullamcorper nisl eget, pharetra tellus. Aenean in imperdiet lectus, vel tempus sem.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)