re = /(?<MyLastParagraph>.*\s)$/
str = 'gula. Morbi tincidunt purus ac pharetra vehicula. Aenean convallis tristique eros hendrerit porttitor.
Morbi tristique massa ligula, vel interdum dui ultricies hendrerit. In blandit ultrices arcu, et accumsan nulla bibendum sed.
Proin quis tortor lacinia, ullamcorper nisl eget, pharetra tellus. Aenean in imperdiet lectus, vel tempus sem.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end