$re = '/[^()\[\]\d]*/';
$str = 'character varying(3)
character varying[]
character varying
numeric
text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);