package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^()\[\]\d]*`)
var str = `character varying(3)
character varying[]
character varying
numeric
text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}