import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(https\\:\\/\\/){1}((t\\.me|telegram\\.me)\\/){1}(joinchat\\/)?(([\\+\\_\\-a-zA-Z0-9])+)$";
final String string = "join https://t.me/+8Wkkhz_JSIJjN2Rk\n"
+ "join https://t.me/+8Wkkhz_JSIJjN2Rk\n"
+ "join https://t.me/+8Wkkhz_JSIJjN2Rk\n"
+ "join https://telegram.me/+8Wkkhz_JSIJjN2Rk\n"
+ "join https://t.me/joinchat/GsyKEdRaawQ3ZDc8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}