#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(https\:\/\/){1}((t\.me|telegram\.me)\/){1}(joinchat\/)?(([\+\_\-a-zA-Z0-9])+)$"
Local $sString = "join https://t.me/+8Wkkhz_JSIJjN2Rk" & @CRLF & _
"join https://t.me/+8Wkkhz_JSIJjN2Rk" & @CRLF & _
"join https://t.me/+8Wkkhz_JSIJjN2Rk" & @CRLF & _
"join https://telegram.me/+8Wkkhz_JSIJjN2Rk" & @CRLF & _
"join https://t.me/joinchat/GsyKEdRaawQ3ZDc8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")