use strict;
my $str = '7532N/10458W
7532/10458
753257/1045843
753257N/1045843E
753257.1/1045843.2
753257.1N/1045843.2E
75:32N/104:58W
75:32/104:58
75:32:57/104:58:43
75:32:57N/104:58:43E
75:32:57.1/104:58:43.2
75:32:57.1N/104:58:43.2E
75*32/10458
75*32\'57"N/104*58\'43"E
75*32\'57.1"/104*58\'43.2"
75*32\'57.1"N/104*58\'43.2"E
75:32/10458
75:3257N/104:58:43E
75:32:57.1/104:5843.2
75:32:57.1N/1045843.2E
';
my $regex = qr/([+-])?(\d\d)\*(?:([0-5]\d)'(?:((?:[0-5]\d)(?:\.\d+)?))?")?([NS])?\/([+-])?([01]\d\d)\*([0-5]\d)'(?:(?:((?:[0-5]\d)(?:\.\d+)?))?")?([EW])?\s/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}