const regex = /([+-])?(\d\d)\*(?:([0-5]\d)'(?:((?:[0-5]\d)(?:\.\d+)?))?")?([NS])?\/([+-])?([01]\d\d)\*([0-5]\d)'(?:(?:((?:[0-5]\d)(?:\.\d+)?))?")?([EW])?\s/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([+-])?(\\d\\d)\\*(?:([0-5]\\d)\'(?:((?:[0-5]\\d)(?:\\.\\d+)?))?")?([NS])?\\\/([+-])?([01]\\d\\d)\\*([0-5]\\d)\'(?:(?:((?:[0-5]\\d)(?:\\.\\d+)?))?")?([EW])?\\s', 'g')
const str = `7532N/10458W
7532/10458
753257/1045843
753257N/1045843E
753257.1/1045843.2
753257.1N/1045843.2E
75:32N/104:58W
75:32/104:58
75:32:57/104:58:43
75:32:57N/104:58:43E
75:32:57.1/104:58:43.2
75:32:57.1N/104:58:43.2E
75*32/10458
75*32'57"N/104*58'43"E
75*32'57.1"/104*58'43.2"
75*32'57.1"N/104*58'43.2"E
75:32/10458
75:3257N/104:58:43E
75:32:57.1/104:5843.2
75:32:57.1N/1045843.2E
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}