package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+?\d{0,2}?[\s.-]?\(?\d{3}\)?[\s.-]?\d{3}[\s.-]?\d{4}`)
var str = `951-719-9170ZoeWellish@superrito.com
PamelaSHill@cuvox.de+1 (217) 569-3204
402-363-6804JaeMDebord@gustr.com
PhanBaLiem@jourrapide.com+1 (732) 636-8246
334-515-7487TimNeudorf@cuvox.de
386-334-5237RafaelCardosoCosta@gustr.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}