#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\+?\d{0,2}?[\s.-]?\(?\d{3}\)?[\s.-]?\d{3}[\s.-]?\d{4}"
Local $sString = "951-719-9170ZoeWellish@superrito.com" & @CRLF & _
"PamelaSHill@cuvox.de+1 (217) 569-3204" & @CRLF & _
"402-363-6804JaeMDebord@gustr.com" & @CRLF & _
"PhanBaLiem@jourrapide.com+1 (732) 636-8246" & @CRLF & _
"334-515-7487TimNeudorf@cuvox.de" & @CRLF & _
"386-334-5237RafaelCardosoCosta@gustr.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")