use strict;
my $str = '0
0 1
0 1 2
0 1 2 3
0
0 00
0 12 1 0
0
0
0
00
0 1 ';
my $regex = qr/^\d$|^\d\s\d$|^\d\s\d\s\d$|^\d\s\d\s\d\s\d$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}