package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d$|^\d\s\d$|^\d\s\d\s\d$|^\d\s\d\s\d\s\d$`)
var str = `0
0 1
0 1 2
0 1 2 3
0
0 00
0 12 1 0
0
0
0
00
0 1 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}