$re = '/^\/topic\/(?:.+-)*(\d+)/m';
$str = '/post/cho-minh-hoi-voi-kien-thuc-ve-cc-va-sql-o-truong-dai-hoc-da-du-de-thuc-tap-chua-vay-moi-nguoi-minh-2131321-nghe-may-nguoi-da-tot-nghiep-noi-la-luc-di-lam-nguoi-ta-ko-dung-nhung-kien-thuc-trong-truong-dai-1321321321';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);