package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/topic\/(?:.+-)*(\d+)`)
var str = `/post/cho-minh-hoi-voi-kien-thuc-ve-cc-va-sql-o-truong-dai-hoc-da-du-de-thuc-tap-chua-vay-moi-nguoi-minh-2131321-nghe-may-nguoi-da-tot-nghiep-noi-la-luc-di-lam-nguoi-ta-ko-dung-nhung-kien-thuc-trong-truong-dai-1321321321`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}