import Foundation
let pattern = #"^(?:[^,]*\,){7}[\s]*(?P<SOURCE_PEER_IP>[\d\w\.:\-_;]+),"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[1508738666710] sdclab010-10-site-1,,TT-0,Diameter,ULA,2001,sdclab010-10-site-1-2_cpf1,sdclab010-10-site-1-2_cpf1:3868,DRA101.epc.mnc002.mcc250.3gppnetwork.org,10.2.37.109,,RT-0,SB-0,,outTR-0,mmec38.mmegi9bdc.mme.epc.mnc002.mcc250.3gppnetwork.org;0;1496330010;1114,4,<ULA P C316 A16777251 H3963173446 E926568828 S8><Session-Id M mmec38.mmegi9bdc.mme.epc.mnc002.mcc250.3gppnetwork.org;0;1496330010;1114/><Origin-Host M PCRF1/><Subscription-Id-Data M No Subscription Id Data/><Framed-IP-Address M No Framed Ip Address/><Product-Name Some Product Name/><Result-Code M 2001/><Origin-Realm M traffixsystems.com/><Auth-Application-Id M 16777251/></ULA>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)