# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[^,]*\,){7}[\s]*(?P<SOURCE_PEER_IP>[\d\w\.:\-_;]+),"
test_str = "[1508738666710] sdclab010-10-site-1,,TT-0,Diameter,ULA,2001,sdclab010-10-site-1-2_cpf1,sdclab010-10-site-1-2_cpf1:3868,DRA101.epc.mnc002.mcc250.3gppnetwork.org,10.2.37.109,,RT-0,SB-0,,outTR-0,mmec38.mmegi9bdc.mme.epc.mnc002.mcc250.3gppnetwork.org;0;1496330010;1114,4,<ULA P C316 A16777251 H3963173446 E926568828 S8><Session-Id M mmec38.mmegi9bdc.mme.epc.mnc002.mcc250.3gppnetwork.org;0;1496330010;1114/><Origin-Host M PCRF1/><Subscription-Id-Data M No Subscription Id Data/><Framed-IP-Address M No Framed Ip Address/><Product-Name Some Product Name/><Result-Code M 2001/><Origin-Realm M traffixsystems.com/><Auth-Application-Id M 16777251/></ULA>"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.