$re = '/^09[0-9]{9}$/';
$str = '09124567890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);