package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^09[0-9]{9}$`)
var str = `09124567890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}