$re = '/([0-9]{3})-([0-9]{3})-([0-9]{4})/m';
$str = 'My number is 212-345-9999.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);