package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{3})-([0-9]{3})-([0-9]{4})`)
var str = `My number is 212-345-9999.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}