package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@(\s+)?.+k\s+[[](\s+)?.+(\s)?[\][msg:\s"].+"[\]]`)
var str = `@
block [
user
][msg:"you messag"]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}