using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@(\s+)?.+k\s+[[](\s+)?.+(\s)?[\][msg:\s""].+""[\]]";
string input = @"@
block [
user
][msg:""you messag""]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}