re = /^block-redirect-https?:\/\/www\.\w+\.\w+$/m
str = 'block-redirect-https://www.arubanetworks.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end