package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^block-redirect-https?://www\.\w+\.\w+$`)
var str = `block-redirect-https://www.arubanetworks.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}