// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<img[^>]*alt="([^"]+)"[^>]*>"#).unwrap();
let string = "<span itemprop=\"description\"> <img src=\"//res.smzdm.com/images/emotions/30.png\" alt=\"[小怒]\" class=\"wp-smiley\"> <img src=\"//res.smzdm.com/images/emotions/30.png\" alt=\"[小怒]\" class=\"wp-smiley\"> <img src=\"//res.smzdm.com/images/emotions/30.png\" alt=\"[小怒]\" class=\"wp-smiley\"> 这文章百度哪里搬来的 </span>
<span itemprop=\"description\"> <img src=\"//res.smzdm.com/images/emotions/36.png\" alt=\"[喜极而泣]\" class=\"wp-smiley\"> 年少无知看了那篇文章好奇买了4瓶 喝了一口差点吐出来 </span>
<span itemprop=\"description\">国内咋就没厂商做点纯气泡水呢,成本应该不高吧,钱都让屈臣氏巴黎水赚去了 <img src=\"//res.smzdm.com/images/emotions/23.png\" alt=\"[皱眉]\" class=\"wp-smiley\"> </span>
<span itemprop=\"description\">小时候就经常煲来喝,利尿排毒 <img src=\"//res.smzdm.com/images/emotions/45.png\" alt=\"[抽烟]\" class=\"wp-smiley\"> </span>
<p class=\"p_content_166651051\"><span itemprop=\"description\">我喜欢香草味的,滑滑的感觉 </span></p>
<p class=\"p_content_166650868\"><span itemprop=\"description\">我喝过好几箱,后来还回购了,再后来就喝不起了,太贵[皱眉] </span></p>";
let substitution = "\\g<1>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}